Apache Struts 2 vulnerability and CafêX software (CVE-2017-5638)