Upgrade CafêX from Java 1.7. to Java 1.8